Vi har oplevet problemer med kunder, som har forsøgt at underskrive og identificere sig med svensk BankID, når de brugte Microsoft Edge-Chromium-browseren.
Ofte er kommet fejl kommet til udtryk som nedenstående billede:
Årsagen til problemerne er en konfiguration for Microsoft Edge til at bruge Internet Explorer-tilstand. Denne konfiguration gælder for Microsoft Edge version 77 og nyere.
Når et login eller underskrift sker med Visma Addo udføres der en omdirigering til webapplikationen. Dette gøres ved at der sendes en HTML-formular med en POST-request.
Det er denne process, der fejler i Microsoft Edge-Chromium-browseren.
Årsag
Årsagen heri findes hos vedkommende, som har valgt at konfigurere Microsoft Edge Chronium i Internet Explorer-tilstand.
Dette kan eksempelvis være for at understøtte webapplikationer, der kun fungerer i Internet Explorer.
Hvis du har denne konfiguration aktiveret vil det kunne ses som følgende:
Løsning
Der findes lige nu to løsninger til dette problem
- Det aktuelle website skal konfigureres som et neutralt site i Entreprise Site Discovery Tool. Konfigurationen skal her stå som none for den aktuelle webside. Du finder infomation om selve denne konfiguration her.
- I stedet for at bruge den SAML2-baserede API mod Visma Addo kan du bruge REST API, hvor dette problem ikke findes.